Firmware Release 20130623

Auto Bulb Ramp light meter improvements, USB stability and Focus Stacking for EOS cameras.


More info and downloads at http://firmware.timelapseplus.com 


I'm getting a error with bulb ramping on a nikon d7000, it will take one picture then stop with the error "ptp error 920c:2001" I'm not getting this with 20130601


The error is that it's trying to control the bulb over USB, which doesn't work yet with Nikon.  Are you using USB alone, or both the adaptor cable and USB?  Using the two together should resolve it, but I'm puzzled why it would have worked with the last version...

I was using both cables, same set up for both of the firmwares tested. I even switched firmwares back and forth a couple times double checking I was doing the same thing on both

Strange -- I'll have to look into that!  I think that if you change Settings->Camera->Interface to 'USB +Cable' it will fix the issue in the new firmware.

I have a D800E and I've just purchased the TL+. I am trying the bulb ramp and I connect both cables. I set it to USB + cable. I am on firmware 20130628. It takes one picture then has a 920C:200F error. It also doesn't work in HDR mode either comes up with the same error message.

 

Sorry for the trouble!  I thought I had that fixed in the last release!  What's happening is that it's trying to close the bulb via USB -- Here's a quick fix for now:


Windows: http://firmware.timelapseplus.com/TLPFW_20130705_WINDOWS.zip 

Windows: http://firmware.timelapseplus.com/TLPFW_20130705_OSX.zip 


And sorry for the slow response -- I'm in the middle of moving and things are a bit messy right now as my office is moved.  It should all be better after tomorrow, though!


Also, I just bought a D3100 which arrived today which will finally allow me to test these things first hand.  I hope to have full USB bulb control for newer Nikon cameras within a week or so now that I can do better testing and reverse engineering.


Thanks for your patience!


Elijah


Hey Elijah,


I see mention of Focus Stacking in this build.  I've got 20130628 installed, but cannot find any mention of this in the menu system (or the online docs).  Any quick pointers?  Thanks!


After having my unit sit on the shelf for the last several months I finally got a chance to bust it out and spent the weekend shooting these Eastern Oregon thunderstorm sequences.  My very first TL shots. It worked great.  Thanks for putting this together.


http://youtu.be/r97a3DJ71ag


-Kevin

Hi Kevin,

I was just looking through some older replies, and I noticed you had a problem in getting Focus Stacking to show up in the menu. It can be found in Trigger -> Focus Stack (if you have a later firmware version installed), and this triggers the Focus Stacking menu.

The menu allows you to set the starting focus level, ending focus level, number of photos, and the focus level change per step. You can also use the menu for operating functions such as start, stop, etc. The display will indicate the button functions for each mode.

On some cameras, focus control won't work unless you use the back button to set AutoFocus on your camera instead of half-press. This prevents triggering AF when taking a photo.

Regards,
James

 

Login or Signup to post a comment