Start a new topic

USB not recognizeby 5dmkii

Hv tried emailing this problem to the support email but no response, so am trying this forum. I connected the otg cable and usb cable to the timelapse+ and then to my 5dmkii, there is no response on the lcd! It does not indicate it has connected. Then i went to click connect, and press usb, it says plug camera into left port...! But its already connected. So i went out to buy a new otg usb, thinking that might be a problem, still the same. Help!

1 person has this problem

Hi Azmi Abdul,

Sorry about the confusion in setting up a USB connection with your Timelapse+. There are several video tutorials that explain how to set up a Timelapse+ to a 5D Mark II, which is basically the same as your camera: http://www.timelapseplus.com/documentation/

These videos explain in detail how to connect the cables, and how set the various operating modes and parameters. There is also a check-list on that goes through a step-by -step procedure on how to set up the TL+ for day-to-night bulb-ramping:  https://www.timelapseplus.com/manual/TLP_Day2Night.pdf

It's important to make sure that the Camera Make, Bulb mode, and Interface parameters are set correctly in Settings -> Camera. When you click: Connect -> USB, The TL+ should display the name of the camera and the current exposure settings (Shutter speed, Aperture, and ISO). If it shows that the camera is not connected, it means that the camera is not set up right. Try changing the mode and/or ISO on the camera while connecting, and the parameters should be displayed on the TL+. This has been known to work on some cameras.

Regards,
James

Tested 2 other cables as well, just to be sure. None works. I don't know if it the unit itself or the red cable that might be damaged. But it does recognize the device has been connected, but seems like no data is being transferred.

Hi Ole-Henrik,

It sounds like your TL+ isn't able to recognize some of the PTP commands needed to establish a USB connection to your camera. An error is generated during the initialization or when it tries to take the first photo. Are there any other error indications shown on the TL+ when it is running?


I reviewed the firmware code, and it appears that your TL+ is getting the “PTP_Connected” signal like it should, but when it does the self-test, it's not getting a “PTP_Ready” signal in response. This causes the TL+ to hang up on “Connected! Retrieving Device Info”.


When you check for a camera connection through: Connect -> USB, the TL+ should then display the name of the camera and the current exposure settings (Shutter speed, Aperture, and ISO). If you don't see these listed, the TL+ won't be able to control them. These parameters may appear if you try changing the mode on the camera and/or the change the ISO. This has been known to work on some cameras.


Here's another test you can do:

  • Make sure Settings->Camera-> Interface is set to “USB Only”
  • Connect the camera via USB alone (no shutter cable)
  • Go to Connect->USB and see if it shows the camera info
  • Press the upper-right button to test taking a photo
  • If the test fails before you can even test a photo, let me know what the error was that displayed

You can also try Trigger->Cable Remote->Photo to see if there are any more errors generated.


Regards,

James




Setting it to "USB Only" instead of "Auto" at least gave me the camera info:

Canon EOS 6D/shutter/aperture/iso


Pressing photo, and it doesn't happen anything, just hangs for a second before it shows "Disconnected" before it connects itself right away again.

Trigger->Cable Remote->Photo works as expected.

Testing some other functions as well, and they seems to work. Probably needed to choose "USB Only", so if only the "test photo" doesn't work, it's not a real problem anymore.


Thanks for your help, at least I can now use my device :]

If you're still having problems with your Timelapse+, maybe you can try updating to the latest firmware.

 

Hey guys, 

Sorry to dig up an old thread but I am having similar issues, the camera name and model shows but the auto configure says it failed to read PC Sync cable, I have attached a quick video, I have seen the checklists and have gone through every step, well I think I have so anyway, I have also reset my 6D to factory settings and also did the same on my 7D and also updated the firmware on the timelapse+ today. The OTG was purchased from you along with the unit itself. Any help will be very much appreciated.


Thankyou!

MOV
(9.78 MB)

Hi Christian,

I checked your video again, and I noticed that you only had one cable connected from the Timelapse+ to the camera when running the Autoconfig routine. In addition to the USB control cable, you need a PC-Sync cable from the AUX port (top right) on the TL+ to the camera's PC-sync (flash sync) port, or hotshoe adaptor, for cameras without a PC-sync port.


The cable is shown on: http://www.timelapseplus.com/buy/pc-sync-cable. If a hotshoe adaptor is needed, it can be found on: http://www.timelapseplus.com/buy/hotshoe-pc-sync-adaptor.

Regards,
James

Login or Signup to post a comment