Start a new topic

sunset to night with milky way in auto bulb ramp settings question / advices


I'm at beginning with Timelapse+, I'd like to try a timelapse with sunset to night / milky way target, but I need some advice or explanation before to do that and shooting a lot photos with wrong settings.

Ok, for example I will start the timelapse just before the sunset and my camera (5D mk2) settings for initial scene is f11, shutter speed 1/15, ISO 50. 

If I set Timelapse+ in AUTO Bulb Ramp Mode with this parameters:

- Bramp Mode: Bulb, A, ISO

- Intrvl Mode Auto (Int Max 30 sec, Int Min 12)

- Aperture Max f2.8, Min f11, 

- ISO max 1600

- Night Target: Milky Way-6

- Duration Time: 3 hours

Now, what I need to understand is: if I start to shooting now, the Timelapse+ start with f11, 1/15, 100 ISO and when reach the total night sky the Timelapse+ arrival to setting in automatic the f2.8 at 1600 ISO or probably is that it stop for example at f5.6, iso 400?

With parameters above mentioned, if in the scene at long distance there are some city lights or light pollution, is probably that light sensor in auto mode don't read the right light level and the Timelapse+ don't reach the 1600 ISO, f2.8 settings?

In this case if auto bulb ramp is not good setting for sunset to night milky way target, please can someone give me some instructions to setting correctly the Timelapse+?

Thank you very much


Hi Sergio,

It's common for beginners to have a few problems in their first attempts at running a bulb-ramp photo sequence. However there is a detailed tutorial on how to get started with automatic bulb ramping on: Elijah explains the set-up process using a 5D Mark II in the "Automatic" video, which is the same as your camera. There is also a check-list on that goes through a step-by-step procedure on how to set up the TL+ for bulb ramping on TL+Day2Night.

I noticed that you set your Aperture Max to f2.8 and your Aperture Min to f11. Bulb ramping won't work with these settings, and the results will be erratic. The Aperture Max needs to be set to f11 and your Aperture Min set to f2.8 instead. I know this is the the opposite of accepted camera terminology, but this is how the TL+ operates.

The bulb ramping photo sequence can be explained as follows: The first photo should be set up on the camera in manual mode so that it appears to have the correct exposure. You should make sure the shutter speed used for your test photo in manual mode matches the StartTv in the TL+. In your case, 1/15 is the StartTv, which is the fastest shutter speed possible. Then with the ISO set to 50, the TL+Day2Night document says to “Adjust the Aperture or add an ND filter or polarizer in order to achieve a good exposure for the current conditions without increasing the shutter speed.” This means the aperture size might have to be reduced to f/8 – f/10, or something like that.

Then as the TL+ is connected, and the camera is switched to bulb mode, the TL+ looks at the camera's initial settings, and creates a new set of !SO, aperture, and shutter speed values base on the EV level of the initial settings (Usually only the shutter speed is adjusted slightly while keeping constant aperture and ISO settings).

If the initial aperture size is anything other than wide open, the document says “It’s recommended to use the lens-twist technique to lock the aperture and avoid flicker (alternatively, the aperture can also be controlled by the Timelapse+ if Settings -> Camera -> Bramp Mode is set to ‘Bulb, A, ISO')”. So we recommend setting Bramp Mode to 'Bulb ,ISO' with the aperture held constant, while the TL+ controls only the ISO and shutter speed.

When running a bulb ramping photo sequence, the TL+ will always set the ISO as low as possible, usually starting at 50. The TL+ will then "ramp" the shutter speed up to it's maximum (which is limited by the Interval time minus the Bramp Pad setting). At this point, the aperture will be moved down a notch, and the shutter speed will again ramp up to its maximum. This process continues until the the aperture is at its minimum (f2.8). At this point, the ISO will finally move to the next higher value (100). Then the aperture will remain at f2.8 while the shutter time is lowered and starts ramping up again to its maximum, which will then trigger the ISO to be increased to 200. This process continues until the Milky Way target settings are reached. So the camera settings at the Night Target exposure will be f2.8 with an ISO of 1600. The final value of ISO will depend on the maximum allowable shutter time (Interval time minus Bramp Pad).

If there are city lights or light pollution in the background, you shouldn't use the Milky Way setting as your Night Target. A setting like "CityLight" or "Half Moon" should give better results. If the background lights are intermittent, you could still use the "Milky Way" setting, but you should increase the "Integration" time setting to filter out these extraneous lights. The TL+ looks at the average of many light readings over the Integration time. You could also make adjustments to the P-I-D tuning parameters in the Bramp Tuning menu to filter the light. (These are explained in the tutorial.)



1 person likes this

Hi James

thank you very much for your explanation, very helpful. I've 2 another questions...I didn't understand very well the first time camera settings in manual mode for to set aperture, iso and shutter speed for a good exposure scene, so I've run the first pc-sync calibration and after auto configuration (Run Autoconfig) for deflickering with a wrong aperture for the scene with result of over exposed or under exposed photos, so the T+ give me the first time a Bulb Min shutter speed of 1/20, second time 1/15 and now I've make a factory reset and I've repeat again the first calibrations with a correct aperture for the current scene (f7.1, 50 ISO, 1/20) and I got reading a Bulb Min of 1/30. At this time I took this reading "1/30" for good and definitive, so I've set T+ StartTv 1/30 (in Timelapse menu / Bulb-ramp) and also in settings menu /camera/Bulb Min. 

This "auto configuration" (from T+ setting/camera/Run Autoconfig) and pc-sync auto calibration should be made only once or every time that I'll make a timelapse?

My second question is, from T+ "Settings -> Time-lapse -> Bramp Tuning-> Integration" after the factory reset I had a "1 minute" value, but reading on the T+ documentation on website I've change this parameter in 20 minutes. Is correct? have you to give me some better advice for this parameter?

At this time is all, thank you very much for help me and greetings from italy


Hi Sergio, 

Sorry about the late response to your questions. I didn't notice this topic in the forum when it was posted.

I guess I don't understand how you got different results for "Bulb Min" when running Auto Configure for different aperture settings. The Auto Configure routine calculates the Bulb Min value based on the time it takes to actuate the shutter after the TL+ send a signal to open or close it. This calculation is independent of the aperture value, so Bulb Min should turn out to be the same no matter what the aperture is set at.

Here are my answers to your two questions:

Question 1: You don't have to run the "Auto Configuration" routine every time you turn on your TL+ or run every time you do a time-lapse. It should only be done one time for each camera. If you try using another camera, the "Auto Configuration" routine should be done again, but only once for that second camera. The TL+ stores all of the configuration parameters for each camera in a separate part of non-volatile memory, so when you turn the TL+ off, all parameters are still retained. The TL+ automatically knows which set of configuration parameters to use when a camera is connected by extracting certain information from the camera when initializing, including the serial number.

Question 2: I checked the values for "Settings -> Time-lapse -> Bramp Tuning -> Integration", and I found that the factory reset actually defaults to 5 minutes. Somehow, this value isn't found when you scroll up and down the listed values for "Integration", and the menu pointer ends up pointing at the first value after the scan, which is 1 minute, because 5 minutes couldn't be found. This is a bug in the program, which we will have to correct.

1 minute is considered to be too short of a time for most time-lapses, and 20 minutes is too long (I will change the documentation for this). A reasonable value is around 5 minutes, so you should manually set Integration to 4 or 6 minutes in the menu. The optimum time depends on your lighting conditions, and you might have to experiment with this to get better results.



Login or Signup to post a comment