Start a new topic

Time lapse plus not working with 5Miii

I finally had an opportunity to shoot some amazing time lapse on my Timelapse plus while on vacation. I followed the tutorial to set up for just a basic Timelapse but it would not trigger the shutter on my 5D Miii. I tried it in both manual and bulb mode and still not working. Not sure if its user error or a my Timelapse is not functioning properly. Please advise. Thanks Shane
1 Comment

Hi Shane,

I thought I'd check to see if you made any progress in getting your Timelapse+ to work properly since you sent this topic in. There are several video tutorials on: http://www.timelapseplus.com/documentation/ that explain how to set up the TL+ in the various modes and interfaces. Most of the videos show a TL+ being used with a Canon 5D Mark II, which is very similar to your camera. If you plan on running bulb-ramping mode, this is explained in the video called "Automatic". There is a also a check-list on that goes through a step-by-step procedure on how to set up the TL+ for bulb-ramping in TL+Day2Night.

Regards,
James

 

Login or Signup to post a comment